Нужна помощь срочно, сбой при обновлении OTRS6.0.26 на 6.0.27

Запросы на решение проблем

Модератор: ykolesnikov

Ответить
AndDem
OTRS Новобранец
Сообщения: 7
Зарегистрирован: 24 окт 2016, 14:18
Контактная информация:

Нужна помощь срочно, сбой при обновлении OTRS6.0.26 на 6.0.27

Сообщение AndDem » 09 апр 2020, 13:57

Добрый день!
При обычном обновлении OTRS с версии 6.0.26 на 6.0.27 во время выполнения команды
otrs.Console.pl Maint::Config::Rebuild получил вот такое сообщение:
otrs.Console.pl Maint::Config::Rebuild
Can't locate Moo.pm in @INC (@INC contains: /opt/otrs/Custom /opt/otrs/Kernel/cp an-lib /opt/otrs /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/ vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /opt/otrs/Kernel/cpan-lib/Math/Random/Secure/RNG.pm line 5.
BEGIN failed--compilation aborted at /opt/otrs/Kernel/cpan-lib/Math/Random/Secur e/RNG.pm line 5.
Compilation failed in require at /opt/otrs/Kernel/cpan-lib/Math/Random/Secure.pm line 8.
BEGIN failed--compilation aborted at /opt/otrs/Kernel/cpan-lib/Math/Random/Secur e.pm line 8.
Compilation failed in require at /opt/otrs/Kernel/System/Main.pm line 23.
BEGIN failed--compilation aborted at /opt/otrs/Kernel/System/Main.pm line 23.
Compilation failed in require at /opt/otrs/Kernel/System/ObjectManager.pm line 3 4.
BEGIN failed--compilation aborted at /opt/otrs/Kernel/System/ObjectManager.pm li ne 34.
Compilation failed in require at /opt/otrs/bin/otrs.Console.pl line 28.
BEGIN failed--compilation aborted at /opt/otrs/bin/otrs.Console.pl line 28.

При попытки запустить otrs.Daemon выдает тоже сообщение. Перезапуск сервера не помог.
Большая просьба помочь разобраться в чем дело и как вернуться на предыдущую версию.
Заранее спасибо!
OTRS 6.0.1
MariaDB 5.5.56
Perl 5.16.3
Centos 7.4

alexus
OTRS Гуру
Сообщения: 5067
Зарегистрирован: 20 сен 2010, 18:17
Откуда: Москва
Благодарил (а): 73 раза
Поблагодарили: 70 раз

Re: Нужна помощь срочно, сбой при обновлении OTRS6.0.26 на 6.0.27

Сообщение alexus » 09 апр 2020, 14:24

Добрый день!

Написал письмо в почту.
С уважением,
Алексей Юсов

Prod: OTRS CE ITSM 6.0.28 on CentOS 7 Apache 2.4 MariaDB 10.4.13 + Radiant Customer Portal

Radiant System OTRS Intergrator RU
Группа OTRS Community в Teleram
Хотите внедрить OTRS? Спросите меня как!

AndDem
OTRS Новобранец
Сообщения: 7
Зарегистрирован: 24 окт 2016, 14:18
Контактная информация:

Re: Нужна помощь срочно, сбой при обновлении OTRS6.0.26 на 6.0.27

Сообщение AndDem » 09 апр 2020, 15:02

Пока вернулся на версию 6.0.26 командой
rpm -Uvh --oldpackage otrs-6.0.26
Сейчас otrs работает корректно.

Пробовать повторно обновить на 27 буду позже
OTRS 6.0.1
MariaDB 5.5.56
Perl 5.16.3
Centos 7.4

Som
OTRS Новобранец
Сообщения: 2
Зарегистрирован: 07 май 2020, 11:59

Re: Нужна помощь срочно, сбой при обновлении OTRS6.0.26 на 6.0.27

Сообщение Som » 07 май 2020, 12:11

В release notes для 6.0.27 нас интересуют следующий пункт:
  • Improved random number generator. We added new CPAN dependencies, which should already be present on all systems: Crypt::Random::Source Exporter::Tiny Math::Random::ISAAC Math::Random::Secure Module::Find Moo Types::TypeTiny namespace::clean
Соответственно надо что бы эти модули были установлены. Я сам ставил по этой инструкции: https://www.thegeekstuff.com/2008/09/ho ... n-command/

Antmit
OTRS Новобранец
Сообщения: 3
Зарегистрирован: 24 фев 2019, 13:07

Re: Нужна помощь срочно, сбой при обновлении OTRS6.0.26 на 6.0.27

Сообщение Antmit » 13 июн 2020, 17:49

Я ставил модули так:

yum install "perl(namespace::clean)"
yum install https://harbottle.gitlab.io/epmel/7/x86 ... elease.rpm
yum install "perl(Moo)"
Антон
OTRS 6.0.28
CentOS 7.4 - 3.10.0-862.14.4
mysql Ver 15.1 Distrib 10.3.10-MariaDB

Ответить