Страница 1 из 2

после обновления с 5.0.26 до 6.0.5 Заявки не открываются!

Добавлено: 01 мар 2018, 23:41
vgusev
Добрый день.

Пытаюсь перейти с 5 на 6 и все никак не выходит.
т.е обновление проходит нормально, скрипт миграции БД, хоть и долго (за 4 часа) но тоже проходит без ошибок, после обновления
Admin > OTRS Group Services > Support Data Collector показывает, что все порядке, но при попытке попасть в любую Заявку (TicketZoom) выдает ошибку.
Сложность в том, что приходится обновлять ночью, поэтому если вы подскажете мне какие данные собрать и что сделать, я бы запланировал работы и попробовал снова.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 02 мар 2018, 05:36
paver
Судя по сообщению об ошибке, у вас вирус.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 02 мар 2018, 16:18
vgusev
ок, сообщение об ошибке..там мало инфы - internal server error bla bla bla
что еще собрать ?
буду делать сегодня ночью, потом придется опять откатиться.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 02 мар 2018, 20:31
alexus
А лог Apache есть с ошибкой?

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 04 мар 2018, 16:13
vgusev
да, действительно, спасибо за наводку, в логе есть вот такая ошибка:

[Sun Mar 04 15:58:45.829326 2018] [:error] [pid 2849] Can't locate object method "ArticleContentIndex" via package "Kernel::System::Ticket" at /opt/otrs//Kernel/Modules/AgentTicketZoom.pm line 742.\n

чд?

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 04 мар 2018, 21:51
alexus
А выложите ваши файлы /opt/otrs/Kernel/Modules/AgentTicketZoom.pm и /opt/otrs/Kernel/System/Ticket.pm сюда

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 05 мар 2018, 21:24
vgusev
в приложении запрашиваемые файлы

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 06 мар 2018, 00:13
alexus
Не знаю как Вы обновлялись, но ваш модуль AgentTicketZoom вообще ни разу не похож на оригинальный от 6ки - https://github.com/OTRS/otrs/blob/maste ... ketZoom.pm
И есть ощущение, что и на стандартный модуль от 5ки он тоже не похож.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 06 мар 2018, 02:36
vgusev
делал вот по этой инструкции: https://2keep.net/upgrade-to-otrs-6/

ровно такой файл, как вы сослались у меня есть, но у него название почему-то AgentTicketZoom.pm.custom_backup
и я смотрю подобных файлов несколько по директории..

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 06 мар 2018, 10:27
alexus
1. Я не знаю никаких инструкций. Есть официальный мануал. Возможно, чьи-то дополнительные мануалы облегчают, но делать надо так - http://doc.otrs.com/doc/manual/admin/st ... ating.html
2. Список пакетов в системе покажите скриншотом.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 07 мар 2018, 00:00
vgusev
1) вы конечно правы, я безусловно начал читать именно с родного мануала.. но в нем нет ни слова про косяк с файлом временной зоны Europe/Moscow! да и ссылку я дал, в ответ на вопрос про то - как я обновлял, ведь там как раз довольно точно описано, именно то, что я делал. впрочем там практически тоже самое, что и в официальном.

2) в приложении запрашиваемый скриншот

3) как вы считаете может мне просто переименовать все файлы AgentTicketZoom.pm.custom_backup с заменой на AgentTicketZoom.pm ? меня смущает, что я не понимаю как и почему это произошло, и как это воспримет система.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 07 мар 2018, 00:59
alexus
vgusev писал(а):3) как вы считаете может мне просто переименовать все файлы AgentTicketZoom.pm.custom_backup с заменой на AgentTicketZoom.pm ?
можно попробовать
vgusev писал(а):меня смущает, что я не понимаю как и почему это произошло,
и меня
vgusev писал(а):и как это воспримет система
должна нормально воспринять. Сравните текст исходников с гитхаба дополнительно

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 07 мар 2018, 12:05
vgusev
спасибо за помощь, я так и не понял почему это произошло, но главное теперь понятно что произошло, и как это фиксить.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 07 мар 2018, 15:53
alexus
Отпишитесь по результатам, плз. И будьте наготове, возможно это не единственный кривой файл. Но методику Вы уже знаете ;)

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 03 июн 2018, 11:05
vgusev
я сделал еще одну попытку миграции с 5 на 6.07 теперь уже

проблема повторилась, опять после обновления появилось пачка файлов с расширением *.pm.custom_backup

я их всех нашел, и заменил на нормальные.
первоначальная ошибка ушла, но теперь при нажатии на тикет возникает вот такая ошибка
error.png
ошибка
error.png (9.71 КБ) 1188 просмотров
через некоторое время окно меняется на это:
error.png
ошибка
error.png (9.71 КБ) 1188 просмотров
в журнале appache такие записи.

[Sun Jun 3 10:17:43 2018] -e: Use of uninitialized value $TemplateContent in substitution (s///) at /opt/otrs//Kernel/Output/Template/Provider.pm line 337.
[Sun Jun 3 10:17:43 2018] -e: Use of uninitialized value in substitution iterator at /opt/otrs//Kernel/Output/Template/Provider.pm line 329.
[Sun Jun 3 10:17:43 2018] -e: Use of uninitialized value $TemplateContent in substitution (s///) at /opt/otrs//Kernel/Output/Template/Provider.pm line 337.
[Sun Jun 3 10:17:43 2018] -e: Use of uninitialized value in substitution iterator at /opt/otrs//Kernel/Output/Template/Provider.pm line 329.
[Sun Jun 03 10:39:07.713835 2018] [autoindex:error] [pid 3933] [client 177.52.30.16:57229] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive
[Sun Jun 03 10:52:39.152039 2018] [autoindex:error] [pid 3923] [client 46.18.151.103:58388] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 03 июн 2018, 11:24
alexus
Поставьте на новый сервер чистый OTRS 6 и проверьте, что всё в порядке. Потом перенесите через бекап данные в вашей системы и смотрите, где проблемы

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 13 июн 2018, 09:54
vgusev
в общем напишу, может кому будет полезно, удалось победить, когда я ПЕРЕД обновлением удалил ВСЕ файлы .custom_backup и .save из opt/otrs

find / \( -name "*.custom_backup" -o -name "*%" \) -exec rm {} \;

после обновления они снова появились, но все вроде поднялось нормально

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются

Добавлено: 05 сен 2018, 07:54
wss
alexus писал(а):
03 июн 2018, 11:24
Поставьте на новый сервер чистый OTRS 6 и проверьте, что всё в порядке. Потом перенесите через бекап данные в вашей системы и смотрите, где проблемы
Здравствуйте. У меня такая же проблема. Не подскажете поподробнее , как перенести данные из 5-й версии в 6-ю?

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются!

Добавлено: 05 сен 2018, 11:43
alexus
Добрый день!
Как такой перенос данных не нужен. Просто обновляется БД - новые таблицы, индексы, структура некоторых данных и т.п. И потом подключается к той же БД.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются!

Добавлено: 05 сен 2018, 12:36
wss
alexus писал(а):
05 сен 2018, 11:43
Добрый день!
Как такой перенос данных не нужен. Просто обновляется БД - новые таблицы, индексы, структура некоторых данных и т.п. И потом подключается к той же БД.
Обновляются вот этим - DBUpdate-to-6.pl?

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются!

Добавлено: 05 сен 2018, 12:49
alexus

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются!

Добавлено: 07 сен 2018, 08:10
wss
alexus писал(а):
05 сен 2018, 12:49
http://doc.otrs.com/doc/manual/admin/6. ... ating.html
Да, этим
По этой инструкции и делаю. Есть один нюанс. Если делаю команду bin/otrs.Console.pl Dev::Tools::Migrate::ConfigXMLStructure --source-directory Kernel/Config/Files , то бд апгрейдится с ошибками. Если без нее то без ошибок, но потом заявки не открываются.

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются!

Добавлено: 07 сен 2018, 13:47
alexus
wss писал(а):
07 сен 2018, 08:10
Если делаю команду bin/otrs.Console.pl Dev::Tools::Migrate::ConfigXMLStructure --source-directory Kernel/Config/Files , то бд апгрейдится с ошибками. Если без нее то без ошибок, но потом заявки не открываются.
Конфиг в 6ке хранится в базе. Надо его импортировать, или перенастроить заново

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются!

Добавлено: 11 сен 2018, 11:39
wss
alexus писал(а):
07 сен 2018, 13:47
wss писал(а):
07 сен 2018, 08:10
Если делаю команду bin/otrs.Console.pl Dev::Tools::Migrate::ConfigXMLStructure --source-directory Kernel/Config/Files , то бд апгрейдится с ошибками. Если без нее то без ошибок, но потом заявки не открываются.
Конфиг в 6ке хранится в базе. Надо его импортировать, или перенастроить заново
А можно поподробнее , в каких файлах?

Re: после обновления с 5.0.26 до 6.0.5 Заявки не открываются!

Добавлено: 17 сен 2018, 11:40
wss
Здравствуйте. Удалось выяснить , что после обновления модуля ITSM не открываются заявки. Обновляю командой :
sudo -u otrs /opt/otrs/bin/otrs.Console.pl Admin::Package::Upgrade ITSM-6.0.10.opm . Пара скриншотов еще. На последнем скриншоте уже обновил 3 модуля. Все работает (заявки открываются).