OTRS.ru • Просмотр темы - Некорректное отображение разделов в "FAQ" у клиентов.

Некорректное отображение разделов в "FAQ" у клиентов.

Обсуждение вопросов и решений

Модератор: ykolesnikov

Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение arthurmorozov » 20 фев 2018, 08:22

Добрый день, коллеги!

После поэтапного обновления с версии 5.0.11 до 6.0.5 согласно официальной инструкции наблюдаем ряд проблем, ниже приведена одна из них:

Некорректное отображение разделов (подразделов) в "FAQ" у клиентов.

Агенты: /index.pl?Action=AgentFAQExplorer
Отображение:
1. Инструкции
2. Шаблоны Заявок

Клиенты: /customer.pl?Action=CustomerFAQExplorer
Отображение:
02. Операционная система.
03. Телефонная связь.
04. Оборудование.
...
2.Шаблоны заявок

Клиент переходя в какой-либо раздел, например,
в "1. Инструкции" (/customer.pl?Action=CustomerFAQExplorer;CategoryID=2) видит верно построенную иерархию подразделов.
в "2. Шаблоны заявок" (/customer.pl?Action=CustomerFAQExplorer;CategoryID=3) видит верно построенную иерархию подразделов.

В базе дынных индексы ответствуют разделам, например,
"1. Инструкции" ID=2, ParentID=0.
"2. Шаблоны заявок" ID=3, ParentID=0.

Проверял модули, дефолтные: /opt/otrs/Kernel/Modules

Agent_FAQ.jpg
Agent_FAQ.jpg (32.01 KIB) Просмотров: 585


Customer_FAQ.jpg
Customer_FAQ.jpg (38.44 KIB) Просмотров: 585


Надеюсь на содействие в решении проблемы.
Последний раз редактировалось arthurmorozov 21 фев 2018, 07:23, всего редактировалось 2 раз(а).
arthurmorozov
OTRS Новобранец
 
Сообщений: 5
Зарегистрирован: 20 фев 2018, 07:50

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение alexus » 21 фев 2018, 00:02

Ничего не понятно. Покажите скриншоты админки FAQ, как видит агент, как видит клиент.
С уважением,
Алексей Юсов

Prod: OTRS ITSM 5.0.14 on CentOS 7 x64 Linux with MySQL 5.7

Radiant System OTRS Intergrator RU
Radiant System OTRS Intergrator EN
Хотите внедрить OTRS? Спросите меня как!
Следите за нашими новостями на Facebook
alexus
OTRS Гуру
 
Сообщений: 4444
Зарегистрирован: 20 сен 2010, 18:17
Откуда: Москва

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение arthurmorozov » 21 фев 2018, 07:42

Есть подозрение на некорректную работу CustomerFAQExplorer.pm в директории /opt/otrs/Kernel/Modules/.
Вложения
PM.rar
(6.18 KIB) Скачиваний: 25
arthurmorozov
OTRS Новобранец
 
Сообщений: 5
Зарегистрирован: 20 фев 2018, 07:50

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение alexus » 21 фев 2018, 11:56

alexus писал(а):Ничего не понятно. Покажите скриншоты админки FAQ, как видит агент, как видит клиент.
С уважением,
Алексей Юсов

Prod: OTRS ITSM 5.0.14 on CentOS 7 x64 Linux with MySQL 5.7

Radiant System OTRS Intergrator RU
Radiant System OTRS Intergrator EN
Хотите внедрить OTRS? Спросите меня как!
Следите за нашими новостями на Facebook
alexus
OTRS Гуру
 
Сообщений: 4444
Зарегистрирован: 20 сен 2010, 18:17
Откуда: Москва

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение arthurmorozov » 21 фев 2018, 12:22

alexus писал(а):
alexus писал(а):Ничего не понятно. Покажите скриншоты админки FAQ, как видит агент, как видит клиент.


В первом посте два снимка экрана - "Agent_FAQ" ("как видит агент") и "Customer_FAQ" ("как видит клиент") с ранее добавленным описанием, что именно Вы хотите увидеть?
arthurmorozov
OTRS Новобранец
 
Сообщений: 5
Зарегистрирован: 20 фев 2018, 07:50

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение alexus » 21 фев 2018, 12:29

1. В первом посте не увидел. А скрин админки FAQ?
2. Попробуйте переустановить пакет FAQ, почистить кэши, проверить в Chrome в режиме инкогнито.
3. Попробуйте создать тестовую структуру FAQ заново, будет ли она отображаться корректно
С уважением,
Алексей Юсов

Prod: OTRS ITSM 5.0.14 on CentOS 7 x64 Linux with MySQL 5.7

Radiant System OTRS Intergrator RU
Radiant System OTRS Intergrator EN
Хотите внедрить OTRS? Спросите меня как!
Следите за нашими новостями на Facebook
alexus
OTRS Гуру
 
Сообщений: 4444
Зарегистрирован: 20 сен 2010, 18:17
Откуда: Москва

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение arthurmorozov » 21 фев 2018, 14:50

alexus писал(а):1. В первом посте не увидел. А скрин админки FAQ?
2. Попробуйте переустановить пакет FAQ, почистить кэши, проверить в Chrome в режиме инкогнито.
3. Попробуйте создать тестовую структуру FAQ заново, будет ли она отображаться корректно

1-2-3 - Не помогло, проблема актуальна.
arthurmorozov
OTRS Новобранец
 
Сообщений: 5
Зарегистрирован: 20 фев 2018, 07:50

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение alexus » 21 фев 2018, 15:05

http://joxi.ru/Vm6aK4XFxLexMr - вот скрин FAQ Агента
http://joxi.ru/p27RZ4xC0PeKnm - вот скрин клиента внутри подкатегории.
Всё корректно работает. Весь скрин не помешало бы делать, чтобы было видно, что в подкатегориях
С уважением,
Алексей Юсов

Prod: OTRS ITSM 5.0.14 on CentOS 7 x64 Linux with MySQL 5.7

Radiant System OTRS Intergrator RU
Radiant System OTRS Intergrator EN
Хотите внедрить OTRS? Спросите меня как!
Следите за нашими новостями на Facebook
alexus
OTRS Гуру
 
Сообщений: 4444
Зарегистрирован: 20 сен 2010, 18:17
Откуда: Москва

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение arthurmorozov » 21 фев 2018, 15:26

alexus писал(а):http://joxi.ru/Vm6aK4XFxLexMr - вот скрин FAQ Агента
http://joxi.ru/p27RZ4xC0PeKnm - вот скрин клиента внутри подкатегории.
Всё корректно работает. Весь скрин не помешало бы делать, чтобы было видно, что в подкатегориях


Дублирую информацию с первого поста:
Агент - администратор, клиент - пользователь. В "админском" (/index.pl?Action=AgentFAQExplorer) интерфейсе тот, что с оранжевым - отображение корректное, а в "пользовательском" (/customer.pl?Action=CustomerFAQExplorer) - отображение некорректное.
arthurmorozov
OTRS Новобранец
 
Сообщений: 5
Зарегистрирован: 20 фев 2018, 07:50

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение alexus » 21 фев 2018, 15:30

По всей ширине экрана скрины покажите.
arthurmorozov писал(а):В "админском" (/index.pl?Action=AgentFAQExplorer) интерфейсе тот, что с оранжевым - отображение корректное, а в "пользовательском" (/customer.pl?Action=CustomerFAQExplorer) - отображение некорректное.

Это понятно. Я просто показал, что на чистой 6ке работает корректно. Надо бы ещё логи апача внимательно посмотреть на момент открытия FAQ в пользовательсоком интерфейсе.
Такое ощущение, что кэши системы и JS старые остались
С уважением,
Алексей Юсов

Prod: OTRS ITSM 5.0.14 on CentOS 7 x64 Linux with MySQL 5.7

Radiant System OTRS Intergrator RU
Radiant System OTRS Intergrator EN
Хотите внедрить OTRS? Спросите меня как!
Следите за нашими новостями на Facebook
alexus
OTRS Гуру
 
Сообщений: 4444
Зарегистрирован: 20 сен 2010, 18:17
Откуда: Москва

Re: Некорректное отображение разделов в "FAQ" у клиентов.

Сообщение bassbot » 18 июн 2018, 22:12

Приветствую!
Подскажите, удалось Вам решить данную проблему?
Столкнулся с похожей ситуацией.
bassbot
OTRS Новобранец
 
Сообщений: 4
Зарегистрирован: 18 июн 2018, 22:04


Вернуться в Общие вопросы

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2